Enter a valid Address

Dec 20, 2007 at 5:54 AM
Edited Dec 21, 2007 at 3:44 AM
After Installing AWR with a developer account for Virtual Earth, we are receiving an error message in Map & Places> Add a place. The error message is "Enter a valid address". We've successfully used the test address in Windows Live Maps. Any assistance in debug would be appreciated
Coordinator
Jan 13, 2008 at 2:47 AM
Hey,

are you still experiencing the issue?

thx
Jan 13, 2008 at 9:57 PM
Hi Augus,

Yes, we are experiencing the issue. We have a test site of AWR 5.0 The Monitor Event log reports "Unable to find address". While the GUI error message is "Enter a valid address"

The webserver event log reported as below. It seems to fail authentication. We have verifed the credentials on our VE developer account
The Virtual Earth Platform developer account credentials test was successful. We are authorized for access to staging.

We have edited the web.config with settings from the VE account
<add key="MapPointFindServiceUrl" value="http://findv3.staging.mappoint.net/Find-30/FindService.asmx"/>
<add key="MapPointUserName" value="TheAccountName"/>
<add key="MapPointPassword" value="AVaildUserpassword">
<add key="MapPointDataSource" value="MapPoint.NA"/>

Any assistance is appreciated

Dave


Event Type: Warning
Event Source: ASP.NET 2.0.50727.0
Event Category: Web Event
Event ID: 1310
Date: 1/13/2008
Time: 12:21:12 PM
User: N/A
Computer: BadBoy
Description:
Event code: 100002
Event message: Unable to find address: "My Home address, So I know Its good"
Event time: 1/13/2008 12:21:11 PM
Event time (UTC): 1/13/2008 8:21:11 PM
Event ID: de6ea807879744569909df069c66f14a
Event sequence: 248
Event occurrence: 1
Event detail code: 0

Application information:

Trust level: Full
Application Virtual Path: /
Application Path: Z\WindowsLiveApps\WLQuickApps.SocialNetwork\WLQuickApps.SocialNetwork.WebSite\
Machine name: OMNI

Process information:
Process ID: 3048
Process name: w3wp.exe
Account name: NT AUTHORITY\NETWORK SERVICE

Exception information:
Exception type: WebException
Exception message: The request failed with HTTP status 401: Unauthorized.

Request information:
Request URL: http://Livefromjapan.jp/Collection/EditItems.aspx?baseItemID=6
Request path: /Collection/EditItems.aspx
User host address: GoodIpaddress
User: MeUser
Is authenticated: True
Authentication Type: Forms
Thread account name: NT AUTHORITY\NETWORK SERVICE

Thread information:
Thread ID: 7
Thread account name: NT AUTHORITY\NETWORK SERVICE
Is impersonating: False
Stack trace: at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at WLQuickApps.SocialNetwork.Business.MapPointService.FindServiceSoap.Find(FindSpecification specification) in Z:\WindowsLiveApps\WLQuickApps.SocialNetwork\WLQuickApps.SocialNetwork.Business\Web References\MapPointService\Reference.cs:line 446
at WLQuickApps.SocialNetwork.Business.MapPointWrapper.GetLatLongByPlace(String place) in Z:\WindowsLiveApps\WLQuickApps.SocialNetwork\WLQuickApps.SocialNetwork.Business\MapPointWrapper.cs:line 165
at WLQuickApps.SocialNetwork.Business.MapPointWrapper.GetLatLong(String formattedAddress) in Z:\WindowsLiveApps\WLQuickApps.SocialNetwork\WLQuickApps.SocialNetwork.Business\MapPointWrapper.cs:line 179


Custom event details:

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Coordinator
Jan 13, 2008 at 10:37 PM
can you try a north america address like 1 Microsoft Way

i dont know if MapPoint has street name resolution in Japan (assuming you are in Japan)

as for the enter a valid email address - i'll log an issue now.
Jan 13, 2008 at 10:50 PM
Edited Jan 13, 2008 at 10:52 PM
Thanks for your reply
I've used this address 1 Microsoft Way, City=Redmond, State= WA, Postal Code= 98052, Country= USA without success. The previous address used was located in Vancouver, BC Apparantly, Mappoint began to server points in Japan late in November. Once we're successfully connected the service we will test those waypoints.





Coordinator
Jan 14, 2008 at 12:37 AM
Hey Dave,

i've got the codebase open now - i'll put in my MWS keys and see what I can come up with.

is it on every page which uses the location control or just registration?
Coordinator
Jan 14, 2008 at 12:58 AM
I've logged the issue here - I dont have a repro - check out the screenshots

http://www.codeplex.com/WLQuickApps/WorkItem/View.aspx?WorkItemId=3249
Feb 15, 2008 at 5:09 PM
The Event 'location' completes successfully along with the Get Directions. The Add Places to Map produces the 'Invalid Address'